WARNING: SSO start-up script has wrong execution priority

Created:

2017-05-19 21:46:39 UTC

Modified:

2017-08-16 16:58:32 UTC

0

Was this article helpful?


Have more questions?

Submit a request

WARNING: SSO start-up script has wrong execution priority

Applicable to:

  • Plesk for Linux

Symptoms

  • Plesk with Customer & Business Manager is used.
  • The following error can be found during post-install/upgrade configuration on the "Try to attach the 'admin' application to SSO" step:

    Try to attach the 'admin' application to SSO............
    The '/usr/share/plesk-billing/sso.php' utility was failed with the unknown message: <message> <html><head> <meta http-equiv="X-UA-Compatible" content="IE=7"/> <title></title> <script> var opt_no_frames = false; var opt_integrated_mode = false; </head><body onLoad=";top.location='/login.php3';"></body><noscript>You will be redirected to the new address in 15 seconds... If you are not automatically taken to the new location, please enable javascript or click the hyperlink <a href="/login.php3" target="top">/login.php3</a>.</noscript></html>
    (HTTP code: 200)</message>. All details of the problem has been stored into the '/usr/share/plesk-billing/sso.crash.log' file.

Cause

There is an incorrect priority in SSO redirect rules, /etc/sw-cp-server/applications.d/sso-cpserver.conf file is used instead of /etc/sw-cp-server/applications.d/00-sso-cpserver.conf .

If Plesk without Customer & Business Manager is used, please ignore this message. This is Plesk bug with ID PPPM-6355 which is planned to be fixed in future Plesk updates.

Resolution

  1. For RHEL-based OS:

    # for i in `find /etc/sw-cp-server/applications.d/ -type f -name *sso-cpserver.conf`; do mv $i $i.moved; done
    # rpm -q sw-sso | xargs rpm -e --nodeps --justdb
    # /usr/local/psa/admin/sbin/autoinstaller --select-release-current --upgrade-installed-components
    # /usr/share/plesk-billing/integration --command=install
    # /usr/share/plesk-billing/integration --command=repair-all

    For Debian-based OS:

    # /usr/local/psa/admin/sbin/autoinstaller --select-release-current --upgrade-installed-components
    # apt-get -f install
    # /usr/share/plesk-billing/integration --command=repair-all
  2. If actions above did not help try the following:

    # for i in `find /etc/sw-cp-server/applications.d/ -type f -name *sso-cpserver.conf`; do mv $i $i.moved; done
    # dpkg --force-all -r sw-sso
    # /usr/local/psa/admin/sbin/autoinstaller --select-release-current --upgrade-installed-components
    # /usr/share/plesk-billing/integration --command=install
    # /usr/share/plesk-billing/integration --command=repair-all
  3. If Customer & Business Manager is not installed on the server please refer to: Warinig during the upgrade: SSO start-up script has wrong execution priority

Have more questions? Submit a request
Please sign in to leave a comment.