upgrade to onyx warning : WARNING: [MYSQL ERROR] Unable to connect database. The reason of problem

Created:

2016-12-18 06:54:51 UTC

Modified:

2017-08-08 13:39:22 UTC

0

Was this article helpful?


Have more questions?

Submit a request

upgrade to onyx warning : WARNING: [MYSQL ERROR] Unable to connect database. The reason of problem

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk Onyx for Linux
  • Plesk Onyx for Windows

Symptoms

  • Upgrade to Plesk Onyx fails with the error

    WARNING: [MYSQL ERROR] Unable to connect database. The reason of problem
  • integration of local MySQL server and Plesk is active, new databases can be provisioned in Plesk without any issues.

Resolution

Verify that admin user can connect to the MySQL server locally:

    # plesk db 
MariaDB [mysql]> use mysql
MariaDB [mysql]> select user,host from user where user='admin';
+-------+-----------+
| user | host |
+-------+-----------+
| admin | localhost |
+-------+-----------+

Ignore this warning and continue with upgrade

Have more questions? Submit a request
Please sign in to leave a comment.