Unable to execute PHP script using PEAR: Failed opening required PHP file

Created:

2016-12-18 06:54:03 UTC

Modified:

2017-08-08 13:25:27 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Unable to execute PHP script using PEAR: Failed opening required PHP file

Applicable to:

  • Plesk 12.0 for Linux

Symptoms

Unable to execute PHP script which is using package from PEAR (PHP Extension and Application Repository).

Similar errors can be found in /var/www/vhosts/example.com/logs/error_log file:

[Sun Jun 12 22:37:38 2016] [warn] [client 203.0.113.2] mod_fcgid: stderr: PHP Fatal error:  require_once(): Failed opening required 'Mail.php' (include_path='.:/opt/plesk/php/5.4/share/pear') in /var/www/vhosts/example.com/httpdocs/script.php on line 2

Cause

Necessary PEAR packages are not installed.

Resolution

Install necessary PEAR packages, for example:

# pear install --alldeps mail
Have more questions? Submit a request
Please sign in to leave a comment.