Applicable to:
- Plesk for Linux
- Plesk for Windows
Symptoms
-
The domain is missing at the Plesk > Domains page.
-
Domain resolves to the correct server.
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The website's files are present on the server.
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Domain has just been migrated.
Cause
There are several possible causes:
-
Browser cache.
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Database inconsistency.
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The domain was created outside of Plesk (if the domain was not migrated to the server via Plesk Migrator).
Resolution
-
Clear the browser cache or open a new browser window in the private mode.
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Log into Plesk on the destination server.
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Go to Plesk > Domains and check if the website present at this page.
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If the issue still persists, source server is up and the migration session, e.g. 203.0.113.2, is still present at the Plesk > Tools & Settings > Migration & Transfer Manager page:
-
Go to Plesk > Subscriptions > example.com and remove the affected subscription which contains non-working domain.
Note: change the "example.com" subscription in the path above to the correct one.
-
Go to Plesk > Tools & Settings > Migration & Transfer Manager > 203.0.113.2
Note: change the "203.0.113.2" source server IP address in the path above to the correct one.
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Press the Reload source data button.
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Migrate the affected subscription one more time.
If the issue still persists and the source server is down:
For Linux-
Connect to the server via SSH.
-
Create a backup of all website content:
Note: change the "example.com" website in the command below to the correct one.
# cp -pR /var/www/vhosts/example.com/ /root/
-
Come back to Plesk and manually create a domain with the same name via Plesk > Domains > Add Domain.
-
Come back to SSH console and remove all files and folders from the domain home folder:
Note: change the "example.com" website in the command below to the correct one.
# rm -rf /var/www/vhosts/example.com/*
-
Restore files and folders from the backup:
Note: change the "example.com" website in the command below to the correct one.
# yes | cp -r /root/example.com /var/www/vhosts/
-
Check and repair website permissions:
Note: change the "example.com" website in the command below to the correct one.
# plesk repair fs example.com
For Windows-
Connect to the server via RDP.
-
Go to the
%plesk_vhost%
folder and find the affected domain. -
Rename the domain folder, e.g. from
example.com
toexample.com.backup
.Note: change the "example.com" website in the example above to the correct one.
-
Come back to Plesk and manually create a domain with the same name via Plesk > Domains > Add Domain.
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Come back to RDP and remove all files and folders from the domain home folder, e.g.
%plesk_vhost%
example.com
:Note: change the "example.com" website in the path above to the correct one.
-
Restore files and folders from the backup, e.g.
example.com.backup
. -
Restore domain permissions using the following command:
Note: change the "example.com" website in the command below to the correct one.
C:\> "%plesk_cli%\repair.exe" --repair-webspace-security -webspace-name example.com
-
Comments
4 comments
For me this worked better when domains were missing:
https://support.plesk.com/hc/en-us/articles/213397749-Not-all-the-domains-are-shown-in-Plesk-Web-Admin-edition
Hello @Remy, thank you for sharing your experience.
Indeed, this issue may have different causes. For your case, it was license type.
Page in comment from Remy above doen't exist anymore.
@André Laguerre
This article was explaining why domains are not shown with different types of licenses, you may refer to this article for such information:https://support.plesk.com/hc/en-us/articles/115001047665-Domains-are-missing-in-Plesk-after-license-downgrade
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