After successful creating a subscription warning appears: Subscription is not synced with service plan

Created:

2016-12-18 06:43:49 UTC

Modified:

2017-08-16 16:06:50 UTC

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After successful creating a subscription warning appears: Subscription is not synced with service plan

Applicable to:

  • Plesk 12.5 for Linux

Symptoms

  • After successful creating a subscription the following messages appear:

    Warning: Subscription is not synced with service plan.
    Information: Subscription example.com was successfully synced with plan Unlimited.
  • It is not clear which resource causes the warning.

  • The subscription is synced.

Cause

This issue has been considered as Plesk bug #PPPM-5336 and will be fixed in future product updates.

Workaround

  1. Download and extract files Subscription.php and CreateSubscription.php from an attached zip-archive ( subscription.zip ):

    # wget https://support.plesk.com/hc/article_attachments/115004383289/subscription.zip
    # unzip subscription.zip
  2. Create a backup of /usr/local/psa/admin/plib/AdminPanel/Form/Subscription.php and /usr/local/psa/admin/plib/Commands/CreateSubscription.php files:

    # mv /usr/local/psa/admin/plib/AdminPanel/Form/Subscription.php{,.back}
    # mv /usr/local/psa/admin/plib/Commands/CreateSubscription.php{,.back}
  3. Copy files from the zip-archive :

    # mv CreateSubscription.php /usr/local/psa/admin/plib/Commands/CreateSubscription.php
    # mv Subscription.php /usr/local/psa/admin/plib/AdminPanel/Form/Subscription.php

Attachments:

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