Unable to send mail from client using secure ports or with PHPMailer: warning: TLS library problem: error:14094418

Created:

2016-12-18 06:43:45 UTC

Modified:

2017-08-08 13:26:18 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Unable to send mail from client using secure ports or with PHPMailer: warning: TLS library problem: error:14094418

Applicable to:

  • Plesk Onyx for Linux

Symptoms

  • After running /usr/local/psa/admin/bin/pci_compliance_resolver utility, PHPMailer does not work and the following records can be found in the /var/log/maillog :

    plesk postfix/smtpd[340542]: connect from example.com[203.0.113.2]
    plesk postfix/smtpd[340542]: SSL_accept error from example.com[203.0.113.2]: 0
    plesk postfix/smtpd[340542]: warning: TLS library problem: error:14094418:SSL routines:SSL3_READ_BYTES:tlsv1 alert unknown ca:s3_pkt.c:1259:SSL alert number 48:
    plesk postfix/smtpd[340542]: lost connection after CONNECT from example.com[203.0.113.2]
    plesk postfix/smtpd[340542]: disconnect from example.com[203.0.113.2]

OR

  • It is not possible to configure a mailbox in email client using secure ports (465 for SMTP, 993 for IMAP, 995 for POP3). The same records can be found in the /var/log/maillog .

Cause

Incorrectly issued or applied certificate.

Resolution

Issue the appropriate certificate and set it as the default for mail:

  1. Go to Tools & Settings > Security > SSL Certificates .
  2. Click [Change] against Certificate for securing mail .
  3. In the list choose the appropriate certificate.
  4. Click OK .

Note: regarding the adding a certificate to the Plesk repository, please check the corresponding article .

Have more questions? Submit a request
Please sign in to leave a comment.