Welcome messages to mail list members are sent after migration

Created:

2016-12-18 06:41:38 UTC

Modified:

2017-04-24 11:21:56 UTC

1

Was this article helpful?


Have more questions?

Submit a request

Welcome messages to mail list members are sent after migration

Applicable to:

  • Plesk 12.5 for Linux

Symptoms

There are domains with mailboxes and mailing list(s) on a Plesk server that were migrated from another server. After the migration, all mail list members received welcome messages about being added to their mail list again. That is confusing for customers. How to disable those messages?

Cause

The wrong Mailman configuration was used during the migration. The issue will be fixed in a future Plesk release.

Resolution

As a workaround, to disable the welcome notifications, set the value of send_welcome_msg in the Mailman configuration to zero on the destination server before the migration:

  1. Back up the original file:

    # cp -p /usr/lib/mailman/bin/add_members /usr/lib/mailman/bin/add_members_backup
    
  2. Replace the following line in /usr/lib/mailman/bin/add_members :

    send_welcome_msg = None
    

    with

    send_welcome_msg = 0
    
  3. Restart Mailman:

    # /etc/init.d/mailman restart
    
  4. Start the migration.

  5. When the migration is finished set send_welcome_msg back to None and restart Mailman.

Have more questions? Submit a request

2 Comments

  • 0
    Avatar
    Greg Sims

    This resolution says, "replace the red line" in step 2 above.  What does this mean?

    It appears that the code for mailman is being modified here (generally not a good idea).  If this is the case, should the original code be restored at some point?  

    Perhaps a better solution is to use this  list configuration option and set it to No:

    set send_welcome_msg (general): Send welcome message to newly subscribed members?

    If this is set on the source server, will you respect it in the migration?

    By the way, this issue have been in Plesk for at least 3 years.

     

     

  • 0
    Avatar
    Artyom Baranov

    Hello Greg,

    Let me answer your questions.

    > This resolution says, "replace the red line" in step 2 above.  What does this mean?

    The knowledge base has been moved to another website recently. This new website does not support coloring so now it is not possible to see the red line.

    > It appears that the code for mailman is being modified here (generally not a good idea).  If this is the case, should the original code be restored at some point?

    I have edited the article by adding the step #5

    > Perhaps a better solution is to use this  list configuration option and set it to No

    This is the solution as well, however, Plesk administrator may not have the password from the client's Mailman administrative interface.

    > If this is set on the source server, will you respect it in the migration?

    The Migrator does not transfer Mailman's settings. These settings will not be changed on the target server after the migration.

    > By the way, this issue have been in Plesk for at least 3 years.

    Our developers are working on the issue, however, I cannot provide you with exact ETA when the issue is fixed.

Please sign in to leave a comment.