Applicable to:
- Plesk for Linux
Symptoms
-
Plesk license was not automatically updated on a server with one of the following messages:
PLESK_WARN: Warning: You are currently operating within the grace period of your product license. To update your product license, select the Retrieve Keys option on the License Management page.
PLESK_WARN: Your license key has expired. To continue using your Plesk, you must purchase a non-expiring commercial license key.
-
The following message is received by Plesk administrator:
CONFIG_TEXT: Unable to update EXT.12345678.1234: an error occurred while processing your key. You can try to retrieve the key manually in Plesk (Tools & Settings > License Management) or let Plesk try to update it in the next 24 hours. If you do not want to receive this notification any more, remove this key from Plesk.
-
The following errors can be found in the
/var/log/plesk/panel.log
file:CONFIG_TEXT: ERR [panel] KeyUpdate Result code: 2 Network failure
ERR [panel] KeyUpdate Result desc: Not valid XML. XML parsing failed
CONFIG_TEXT: ERR [panel] KeyUpdate Result code: 2 Network failure
ERR [panel] KeyUpdate Result desc: Not valid XML. no element found
CONFIG_TEXT: TLSv1.2 (OUT), TLS header, Certificate Status (22): > SSL data removed for security reason
* TLSv1.2 (OUT), TLS handshake, Client hello (1): > SSL data removed for security reason
* Unknown SSL protocol error in connection to ka.plesk.com:5224 * Closing connection 0 cURL verbose output:
* Could not resolve host: ka.plesk.com * Closing connection 0
Cause
The corrupted file /etc/sw/keys/registry.xml
or Plesk licensing server (Key Administrator) is overloaded with the same requests.
Resolution
-
Connect to the server via SSH.
-
Remove the
/etc/sw/keys/registry.xml
file:# rm /etc/sw/keys/registry.xml
-
Log out from Plesk interface and log into back to recreate the removed
/etc/sw/keys/registry.xml
file. -
Run Daily Maintenance task to update keys on the server:
# plesk daily
Comments
4 comments
The expression as explained in Option 1 seems to be the easiest solution. Why isn't this single line of code included by default? As the solution is already clear, that should be part of the next microupdate!
In addition, the article might let the reader assume that you should shift the task exactly by +/- 1 hour or +/-30 minutes (first sentence in Option 1). But since that basically brings the server to the next/previous time zone, the problem might appear again. Using a random time seems more appropriate.
For option 2: is there a reason why you gave the time range of +/- 30 minutes? Would it hurt if the job starts much earlier/later?
@b_p , solution in Option 1 is not a proper one, the recommended way to change execution time for Daily Maintenance is through task scheduler like cron or anacron.
About random time for DailyMaintenance task there is a feature request https://plesk.uservoice.com/forums/184549-feature-suggestions/suggestions/18978205 and I assume you have voted for this already.
> For option 2: is there a reason why you gave the time range of +/- 30 minutes? Would it hurt if the job starts much earlier/later?
The main requirement for the start time is to run DailyMaintenance task when the server load is minimal.
Thank you for the input, the article has been updated.
Didn't help.. Although I get frequent email warnings about key being expired and some features are now not available.... I wonder if that email is wrong..
# rm /etc/sw/keys/registry.xml
# /usr/local/psa/admin/bin/php /usr/local/psa/admin/plib/DailyMaintainance/task-script.php UpdateKeys --period=daily
[2022-09-21 12:14:40.527] 18456:632ad5f97a3d8 ERR [panel] KeyUpdate Result code: 2 Unspecified error
[2022-09-21 12:14:40.527] 18456:632ad5f97a3d8 ERR [panel] KeyUpdate Result desc: License key is not prolongated yet
#
Hello turgut kalfaoglu,
According to the error message, your key has expired. Consider contacting our Customer Success Team for further clarification of the issue: https://www.plesk.com/licensing-and-purchase-support/.
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