PHP include_path variable remains the same after changing version of PHP handler

Created:

2016-12-18 06:53:46 UTC

Modified:

2017-08-08 13:37:53 UTC

0

Was this article helpful?


Have more questions?

Submit a request

PHP include_path variable remains the same after changing version of PHP handler

Applicable to:

  • Plesk 12.5 for Linux

Symptoms

File php.ini not showing the right parameters of the php handler after assigning a new one in PHP settings for a specific domain; include_path variable has a value with wrong PHP version.

Cause

include_path PHP value is not changed along with the change of PHP version when settings.general.include_path.custom=false is set in panel.ini . This is a software bug with id #PPPM-5389 that will be fixed in future Plesk updates.

Resolution

Try one of the following solutions:

  1. Comment out settings.general.include_path.custom=false and change include_path in subscription settings.

  2. Modify /var/www/vhosts/system/example.com/etc/php.ini to make include_path setting correct.

Have more questions? Submit a request
Please sign in to leave a comment.