Unable to send or receive email: SMTP session hangs on RCPT TO

Created:

2016-12-18 06:51:27 UTC

Modified:

2017-08-08 13:42:50 UTC

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Unable to send or receive email: SMTP session hangs on RCPT TO

Applicable to:

  • Plesk 12.5 for Windows

Symptoms

  • Unable to send or receive email via MailEnable Standard Edition.

  • When mail software tries to send an email to your domain, upon issuing the SMTP RCPT TO command, there is an extremely long delay. SMTP logs in the MailEnable Activity log show QUIT command after RCPT TO without DATA command.

Cause

Scripts were enabled in HKEY_LOCAL_MACHINE\\SOFTWARE\\Wow6432Node\\Mail Enable\\Mail Enable\\Connectors\\SMTP\\Scripts section, but not configured properly, as a result all SMTP connections hangs on attempt to find and execute script after RCPT TO command.

Resolution

  1. Backup registry HKEY_LOCAL_MACHINE\\SOFTWARE\\Wow6432Node\\Mail Enable into a file.

    reg export "HKLM\\SOFTWARE\\Wow6432Node\\Mail Enable" MailEnable_Backup.reg
  2. Remove Scripts registry key.

    reg delete /va "SOFTWARE\\Wow6432Node\\Mail Enable\\Mail Enable\\Connectors\\SMTP\\Scripts"
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