After upgrade to Onyx error in website log: mod_fcgid: can't write spawn command

Created:

2016-12-18 06:50:44 UTC

Modified:

2017-08-08 13:45:20 UTC

1

Was this article helpful?


Have more questions?

Submit a request

After upgrade to Onyx error in website log: mod_fcgid: can't write spawn command

Applicable to:

  • Plesk Onyx for Linux

Symptoms

  1. Plesk was upgraded to Plesk Onyx.

  2. The following error can be found in the /var/www/vhosts/system/example.com/logs/error_log :

    [fcgid:warn] [pid 21944] (32)Broken pipe: [client 203.0.113.2:13631] mod_fcgid: can't write spawn command
  3. The following can be found in /var/log/httpd/access_log :

    "GET / HTTP/1.0" 200 38801 "-" "Mozilla/5.0 (compatible; monitis - premium monitoring service; http://www.monitis.com)"
  4. The error disappears after Apache restart, but after some time happens again.

Cause

  1. Monitis service increases the load on mod_fcgid .

  2. The value of FcgidMaxProcesses parameter is not efficient.

Resolution

  1. Set the value of FcgidMaxProcesses in /etc/httpd/conf.d/fcgid.conf according to the number of websites hosted on the server (it should be equal or slightly more).

  2. Restart Apache webserver to apply the changes:

    # service httpd restart
Have more questions? Submit a request
Please sign in to leave a comment.