Webmail funktioniert nicht: „Connection reset by peer: mod_fcgid: error reading data from FastCGI server“

Created:

2016-11-16 13:10:33 UTC

Modified:

2017-08-08 13:23:39 UTC

0

Was this article helpful?


Have more questions?

Anfrage einreichen

Webmail funktioniert nicht: „Connection reset by peer: mod_fcgid: error reading data from FastCGI server“

Applicable to:

  • Plesk

Kennzeichen

  1. Horde Webmail zeigt folgende Fehlermeldung:

    Service Temporarily Unavailable  The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later. Apache Server at webmail.testdomain.com Port 80
    

    Auch in den Horde Protokollen wird ein Fehler angezeigt:

    [Wed Sep 25 21:01:41 2013] [warn] [client 11.22.33.44] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server
    [Wed Sep 25 21:01:41 2013] [error] [client 11.22.33.44] Premature end of script headers: index.php
    
  2. Während der Migration von einem anderen Server erscheint eine Warnmeldung:

    WARNING:()The webmail service horde is unavailable. It will be replaced with <webmail> for the following objects: <list of domains>
    

Ursache

  1. Falsche Berechtigungen für ' /var/www/cgi-bin/cgi_wrapper '

    [root@plesk ~]# ls -ld /var/www/cgi-bin/cgi_wrapper
    drwxr-xr-- 2 rgs psaserv 4096 Apr 14 13:32 /var/www/cgi-bin/cgi_wrapper
    
  2. Horde wurde falsch installiert.

Lösung

  1. Korrigieren Sie die Berechtigungen:

    root@plesk:~# chown root:root /var/www/
    root@plesk:~# chown root:root /var/www/cgi-bin/
    root@plesk:~# chown root:root /var/www/cgi-bin/cgi_wrapper/cgi_wrapper*
    root@plesk:~# chmod 755 /var/www/cgi-bin/cgi_wrapper
    
  2. Wenn Sie nach der Korrektur der Berechtigungen den Fehler 'Unable to get webmail password!' sehen, sollten Sie in diesem Artikel der Wissensdatenbank lesen: http://kb.sp.parallels.com/de/115742

  3. Sollte der Schritt 2 das Problem nicht beheben, müssen Sie das Horde-Paket neu installieren:

    # rpm -q psa-horde
    psa-horde-5.1.4-cos5.build115130916.13
    
    # rpm -e psa-horde-5.1.4-cos5.build115130916.13 --nodeps
    
    # /usr/local/psa/admin/bin/autoinstaller
    
Haben Sie Fragen? Anfrage einreichen
Bitte melden Sie sich an, um einen Kommentar zu hinterlassen.