Plesk Upgrade fehlgeschlagen: ERROR 1524 (HY000): Plugin 'Y' is not loaded

Created:

2016-11-16 13:07:49 UTC

Modified:

2017-08-16 16:28:37 UTC

0

Was this article helpful?


Have more questions?

Anfrage einreichen

Plesk Upgrade fehlgeschlagen: ERROR 1524 (HY000): Plugin 'Y' is not loaded

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 12.0 for Linux

Kennzeichen

Plesk Upgrade schlägt fehl. Die folgende Fehlermeldung wird angezeigt:

ERROR 1524 (HY000): Plugin 'Y' is not loaded

Im Protokoll /var/log/mysqld.log finden Sie die entsprechende Warnmeldung:

150824 20:12:02 [Warning] 'user' entry 'pma_YDHnd4Ja5pfe@localhost' has both a password and an authentication plugin specified. The password will be ignored.

Ursache

Falscher Wert in mysql -Datenbank

Lösung

  1. Erstellen Sie ein Backup der mysql -Datenbank:

    mysqldump -uadmin -p`cat /etc/psa/.psa.shadow` mysql > mysql.sql
  2. Überprüfen Sie den plugin -Wert auf den erwähnten Benutzer:

    mysql> select plugin from mysql.user where User like '%pma_YDHnd4Ja5pfe%' \\G
    *************************** 1. row ***************************
    plugin: Y
    1 rows in set (0.00 sec)
  3. Entfernen Sie den falschen Wert mithilfe der folgenden Abfrage:

    mysql> update mysql.user set plugin = '' where User like '%pma_YDHnd4Ja5pfe%';
    Query OK, 1 row affected (0.01 sec)
    Rows matched: 1 Changed: 1 Warnings: 0
Haben Sie Fragen? Anfrage einreichen
Bitte melden Sie sich an, um einen Kommentar zu hinterlassen.