Backups are not shown in Server Backup Repository for all Parallels Plesk Panel clients/domains

Created:

2016-11-16 13:06:05 UTC

Modified:

2017-08-16 16:01:03 UTC

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Backups are not shown in Server Backup Repository for all Parallels Plesk Panel clients/domains

Applicable to:

  • Plesk 12.0 for Linux
  • Plesk 11.5 for Linux
  • Plesk 10.4 for Linux/Unix
  • Plesk 10.3 for Linux/Unix
  • Plesk 12.0 for Windows
  • Plesk 11.5 for Windows

Symptoms

a. You changed the ' DUMP_D ' directive value in /etc/psa/psa.conf and moved all data from a server backup repository to the location specified in ' DUMP_D '. However, backups are not shown in the server backup repository

# /usr/local/psa/admin/bin/pmm-ras --get-dump-list --dump-storage=/backup/ --type=server
Transport error: Unable to list dir some/non-plesk/folder: boost::filesystem::last_write_time: No such file or directory: "/backup/some/non-plesk/folder/file"

b. You created a new backup to the server backup repository and verified that the backup exists in the file system:

    # ls -l /var/lib/psa/dumps/clients/parallels.client/
    -rw-r----- 1 root root 3089 Aug 27 12:07  parallels.10.test_parallels.client_info_1008271207.xml 

However, the backup is not shown in the control panel ( Clients -> Parallels Client -> Backup Manager -> Server Repository ).

In the backup log ( /usr/local/psa/PMM/logs/pmmcli.log ), you see an error message like:

31975: 2010-08-27 12:08:17,532 INFO Executing <subprocess[31976] '/usr/local/psa/admin/bin/pmm-ras --get-dump-list --type=client --guid=e254eaf4-3228-47f0-869b-026a4cf236c8 --id=20 --name=parallels.client --session-path=/usr/local/psa/PMM/logs'> 
31975: 2010-08-27 12:08:17,570 INFO Subprocess raised ExecuteException: Subprocess <subprocess[31976] '/usr/local/psa/admin/bin/pmm-ras --get-dump-list --type=client --guid=e254eaf4-3228-47f0-869b-026a4cf236c8 --id=20 --name=parallels.client --session-path=/usr/local/psa/PMM/logs'> was finished with exit code -11 
== STDOUT ==================== 
== STDERR ==================== 
 31975: 2010-08-27 12:08:17,570 DEBUG <pmmcli.GetDumpsListAction object at 0xb7eed4cc>: response 
31975: 2010-08-27 12:08:17,571 INFO Outgoing packet: 
<?xml version="1.0" encoding="UTF-8"?> 
<response> 
    <errcode>0</errcode> 
    <errmsg>pmm-ras error (Error code = -11): 
== STDOUT ====================

Cause

a. For Parallels Plesk 11.x

Invalid permissions and/or broken symlinks in ' DUMP_D ' for files that are not related to Plesk backup data.

b. For Parallels Plesk 9.5

Parallels Plesk segfaults when testing new and old backups created through Parallels Plesk.

Resolution

a. Parallels Plesk 11.x

Make sure that the ' DUMP_D ' folder: 1. Is owned by the psaadm user and group, with access permissions 0755 :

# ls -ld /backup/
drwxr-xr-x 7 psaadm psaadm 12288 Jan 28 05:22 /backup/
  1. Does not contain any other other files/folder not related to Plesk backups.

b. Parallels Plesk 9.5

The fixed pmm-ras file for CentOS 5 x86 is in the attached file.

To fix the installation, replace %plesk_dir%/admin/sbin/pmm-ras , file-by-file, from the attachment and correct the owner and permissions. They should be root:root and 550 .

You can correct permissions with the commands chown and chmod :

# chown root:root /usr/local/psa/admin/sbin/pmm-ras
# chmod 550 /usr/local/psa/admin/sbin/pmm-ras

Note: %plesk_dir% is the environment variable that points to the Parallels Plesk installation folder. By default, this is /usr/local/psa/ .

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