[FIX] "Domain does not exist" error message when accessing webdirectories of a domain in PP

Created:

2016-11-16 13:22:16 UTC

Modified:

2017-08-08 13:15:42 UTC

0

Was this article helpful?


Have more questions?

Anfrage einreichen

[FIX] "Domain does not exist" error message when accessing webdirectories of a domain in PP

Applicable to:

  • Plesk for Windows

Symptoms

Symptom 1:

The following error message is displayed in "Web Directories" when accessing it from the domain management page:

WebServerManager::getWebDirs() failed: websrvmng failed: Site domain.com doesn't exist
---------------------- Debug Info -------------------------------
0: C:\\Program Files\\SWsoft\\Plesk\\admin\\htdocs\\domains\\webdirs\\webdirs.php:48 psaerror(string "WebServerManager::getWebDirs() failed: websrvmng failed: Site domain.com doesn't exist")

Symptom 2:

The following error message appears when I try to recalculate statistics verbosely:

statistics.exe --verbose
...
Execute websrvmng --get-vhost-log-dir --vhost-name=domain.com failed with error code 1: Site domain.com doesn't exist

Cause

The error message means that "domain.com" is absent from IIS or is not configured in IIS.

Resolution

The site needs to be configured using the following commands:

"%plesk_bin%\websrvmng.exe" --remove-vhost --vhost-name=domain.com
"%plesk_bin%\websrvmng.exe" --reconfigure-vhost --vhost-name=domain.com
Haben Sie Fragen? Anfrage einreichen
Bitte melden Sie sich an, um einen Kommentar zu hinterlassen.