Upgrade der PHP-Version unter Debian

Created:

2016-11-16 12:51:27 UTC

Modified:

2017-05-26 12:08:37 UTC

15

Was this article helpful?


Have more questions?

Anfrage einreichen

Upgrade der PHP-Version unter Debian

Frage

Wie kann ich ein Upgrade der auf Debian installierten PHP-Version auf 5.4/5.5/5.6 durchführen?

Antwort

Hinweis: Plesk unterstützt offiziell im Lieferumfang enthaltene Pakete sowie Systempakete und Pakete von offiziellen System-Repositorys.

Wenn Ihr System keine neuere Version von PHP-Paketen in offiziellen Repositorys hat, sollten die Pakete manuell kompiliert oder von einem Drittanbieter-Repository installiert werden.

Dieses PHP-Upgrade ist eine rein administrative Aufgabe und sollte von ihrem Administrator vor Ort durchgeführt werden. Dieser Vorgang ist nicht im Odin Support vorgesehen.

Hier finden Sie ein Beispiel, wie PHP mithilfe eines Drittanabieter-Repositorys auf Debian aktualisiert werden kann:

  1. Fügen Sie die Repository-Liste zu sources.list hinzu.

    Abhängig von Ihrer Distribution (Jessie, Wheezy oder Squeeze) fügen Sie diese beiden Zeilen zur Datei /etc/apt/sources.list hinzu. Sie können auch einen Datenspiegel in Ihrer Nähe auswählen:

    deb http://packages.dotdeb.org jessie all
    deb-src http://packages.dotdeb.org jessie all

    oder

    deb http://packages.dotdeb.org wheezy all
    deb-src http://packages.dotdeb.org wheezy all

    oder

    deb http://packages.dotdeb.org squeeze all
    deb-src http://packages.dotdeb.org squeeze all
  2. Optionen

    Wenn Sie folgende Elemente installieren möchten, führen Sie die entsprechenden Schritte aus:
    PHP 5.6 auf Debian 7 "Wheezy"� (ohne Zend Thread Safety). Fügen Sie diese beiden Zeilen hinzu:

    deb http://packages.dotdeb.org wheezy-php56 all
    deb-src http://packages.dotdeb.org wheezy-php56 all

    PHP 5.6 auf Debian 7 "Wheezy"� (mit Zend Thread Safety). Fügen Sie stattdessen diese beiden Zeilen hinzu:

    deb http://packages.dotdeb.org wheezy-php56-zts all
    deb-src http://packages.dotdeb.org wheezy-php56-zts all

    PHP 5.5 auf Debian 7 "Wheezy". Fügen Sie diese beiden Zeilen hinzu:

    deb http://packages.dotdeb.org wheezy-php55 all
    deb-src http://packages.dotdeb.org wheezy-php55 all

    PHP 5.4 auf Debian 6 "Squeeze". Fügen Sie diese beiden Zeilen hinzu:

    deb http://packages.dotdeb.org squeeze-php54 all
    deb-src http://packages.dotdeb.org squeeze-php54 all
  3. Rufen Sie den GnuPG-Schlüssel ab und installieren Sie ihn.

    wget http://www.dotdeb.org/dotdeb.gpg
    sudo apt-key add dotdeb.gpg
  4. Installieren Sie das gewünschte Element.

    apt-get update  
    apt-get install php5

Hinweis : Nicht gelistete PHP-Versionen sollten manuell kompiliert werden. Im Fall von Problemen beim Kompilieren von PHP oder der Installation von Drittanbieter-Repositorys lesen Sie die PHP-Dokumentation oder wenden Sie sich für weitere Hilfe an Ihren Administrator vor Ort.

Haben Sie Fragen? Anfrage einreichen
Bitte melden Sie sich an, um einen Kommentar zu hinterlassen.