Potenzielle Probleme bei dist-upgrade

Created:

2016-11-16 12:49:37 UTC

Modified:

2017-07-20 22:17:17 UTC

6

Was this article helpful?


Have more questions?

Anfrage einreichen

Potenzielle Probleme bei dist-upgrade

Dist-upgrade ist kein einfacher Vorgang. Sie benötigen dazu umfangreiche Erfahrung als Systemadministrator sowie mit dem System und seinen Komponenten.
Während oder nach dem Ausführen von dist-upgrade können Probleme auftreten, die Sie mithilfe dieses Artikels lösen können.

Bevor Sie mit dist-upgrade beginnen, lesen Sie sich die entsprechende Anleitung in der Dokumentation des Betriebssystemanbieters durch:
Debian 6 auf Debian 7
Debian 7 auf Debian 8
Ubuntu 12 bis Ubuntu 14

Um potenzielle Probleme zu vermeiden, führen Sie die Schritte im Artikel #126808 aus.

Inhalt

Allgemeine Fehler während dist-upgrade

  • Das Paket 'plymouth' hat nicht erfüllte Abhängigkeiten.

    Dist-upgrade schlägt fehlt. Es wird die folgende Fehlermeldung angezeigt:

        # apt-get dist-upgrade 
    Reading package lists...
    Done Building dependency tree
    Reading state information...
    Done Calculating upgrade... Failed
    The following packages have unmet dependencies:
    udev : Breaks: plymouth (< 0.9.0-7) but 0.8.5.1-5 is to be installed
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

    Das Paket 'plymouth' hat nicht erfüllte Abhängigkeiten.
    Entfernen Sie dieses Paket und führen Sie dist-upgrade erneut aus.

  • Sofortige Konfiguration konnte nicht durchgeführt werden

    Dist-upgrade schlägt fehlt. Es wird die folgende Fehlermeldung angezeigt:

    E: Could not perform immediate configuration on...

    Führen Sie Folgendes aus:

    # apt-get dist-upgrade -o APT::Immediate-Configure=0
  • Fehler beim Abrufen der D-Bus-Verbindung

    Nach dist-upgrade schlagen einige Dienste mit dieser Fehlermeldung fehl:

    Failed to get D-Bus connection: Unknown error -1
    Switching to 'systemd' system initialization service was not completed:

    # ps -p 1 -o comm=
    init
    1. Entfernen Sie die Datei /etc/apt/preferences.d/local-pin-init und installieren Sie das Paket 'systemd-sysv':

      # rm -f /etc/apt/preferences.d/local-pin-init
      # apt-get install systemd-sysv
    2. Starten Sie den Server neu.

    3. Reparieren Sie die Plesk Dienste:

      # plesk repair installation
  • Kein öffentlicher Schlüssel verfügbar

    Bei der Eingabe des Befehls #apt-get update werden Warnmeldungen angezeigt:

    N: Ignoring file '50sw_autoinstaller.list.saved_by_plesk_distupgrade' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
    W: There is no public key available for the following key IDs:
    9D6D8F6BC857C906
    W: There is no public key available for the following key IDs:
    7638D0442B90D010

    Sie können die Meldungen ignorieren. Falls Sie sie jedoch entfernen möchten, installieren Sie einen Schlüsselbund:

    # apt-get install debian-archive-keyring
  • initscripts: Unterbrechung: nfs-common

    Der Befehl dist-upgrade schlägt fehl, wenn nfs-common installiert ist. Die folgende Fehlermeldung wird angezeigt:

    # apt-get dist-upgrade
    Calculating upgrade... Failed
    The following packages have unmet dependencies:
    initscripts : Breaks: nfs-common (< 1:1.2.5-3) but 1:1.2.2-4squeeze2 is to be installed
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

    Entfernen Sie das Paket nfs-common , um mit dem Upgrade fortzufahren:

    #apt-get remove nfs-common
  • Sofortige Konfiguration für 'mysql-server-5.5' konnte nicht durchgeführt werden

    Der Befehl dist-upgrade schlägt fehl. Die folgende Fehlermeldung wird angezeigt:

    E: Could not perform immediate configuration on 'mysql-server-5.5'. Please see man 5 apt.conf under APT::Immediate-Configure for details. (2)

    Es kommt zu diesem Fehler, wenn das Paket libc6-dev installiert ist. Für mysql-server ist jedoch gcc-4.4 erforderlich. Installieren Sie die fehlenden Pakete, um mit dem Upgrade fortzufahren:

    # apt-get install gcc-4.4
    # apt-get install mysql-server-5.5
  • Zugriff auf Horde-Webmail nicht möglich

    Für Horde-Webmail wird nach der Authentifizierung ein Fehler angezeigt:

    Call to a member function write() on NULL

    In /var/log/maillog werden die folgenden Datensätzen angezeigt:

    Dec 18 22:03:23 testpar1 courier-imapd: Connection, ip=[::ffff:127.0.0.1]
    Dec 18 22:03:23 testpar1 courier-imapd: authdaemon: s_connect() failed: No such file or directory
    Dec 18 22:03:24 testpar1 courier-imapd: LOGIN FAILED, method=PLAIN, ip=[::ffff:127.0.0.1]
    Dec 18 22:03:24 testpar1 courier-imapd: authentication error: No such file or directory

    Reparieren Sie die E-Mail-Serverkonfiguration:

    # plesk repair mail
  • Plesk Skript vor dem Upgrade gibt zurück, dass das Paket nicht aktualisiert ist

    Das Plesk Skript vor dem Upgrade von Debian 7 auf Debian 8 gibt die folgende Meldung zurück:

    The following packages are not up-to-date:
    db4.8-util
    You should install the latest updates before performing dist-upgrade

    Aktualisieren Sie das Paket db4.8-util manuell:

    # apt-get install --only-upgrade db4.8-util
  • SpamAssassin-E-Mail-Filter-Daemon wird neu gestartet: NetAddr/IP.pm wurde nicht gefunden

    Dist-upgrade schlägt fehl. Ein SpamAssassin-Fehler wird angezeigt:

    Restarting SpamAssassin Mail Filter Daemon: Can't locate NetAddr/IP.pm in
    @INC (you may need to install the NetAddr::IP module) (@INC contains:
    /usr/share/perl5 /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.20.2
    /usr/local/share/perl/5.20.2 /usr/lib/x86_64-linux-gnu/perl5/5.20
    /usr/lib/x86_64-linux-gnu/perl/5.20 /usr/share/perl/5.20
    /usr/local/lib/site_perl) at /usr/share/perl5/Mail/SpamAssassin/NetSet.pm
    line 25.

    Schließen Sie die Installation von Paketen mithilfe dieses Befehls ab:

    # apt-get -f install

    Führen Sie dist-upgrade aus:

    # apt-get dist-upgrade
  • Dist-upgrade ist aufgrund des udev-Pakets fehlgeschlagen

    dist-upgrade schlägt fehl. In der Fehlermeldung wird zurückgegeben, dass kein Upgrade für das udev-Paket durchgeführt werden kann, da kein Upgrade für Kernel vorhanden ist.

    Schließen Sie die Installation von Paketen mithilfe dieses Befehls ab:

    # apt-get -f install

    Führen Sie dist-upgrade aus:

    # apt-get dist-upgrade

    Wiederholen Sie apt-get -f install und apt-get dist-upgrade , bis nur mehr das Paket 'udev' für ein Upgrade übrig ist.

    Starten Sie den Server neu.Schließen Sie dist-upgrade ab:

    # apt-get dist-upgrade
  • Für einige wichtige Plesk Komponenten wurde kein Upgrade durchgeführt: panel

    Das Skript /opt/psa/bin/distupgrade.helper.deb7-deb8_post.x64.sh endet nach dem Upgrade über dist-upgrade von Debian 7 auf Debian 8 mit dieser Meldung:

    Some of essential Plesk components are not upgraded: panel
    You may either upgrade them manually upgrade them or rerun utility with option --skip-check-latest
    Some error during dist-upgrade post stage occurs.

    Das Horde-Paket wurde auch entfernt.

    Bevor Sie das Skript /opt/psa/bin/distupgrade.helper.deb7-deb8_post.x64.sh nach dem Upgrade ausführen, geben Sie den folgenden Befehl ein:

    # apt-get install psa-phpfpm-configurator
  • Nicht erfüllte Abhängigkeiten für libmyodbc

    Während des Upgrades von Debian 6 auf Debian 7 sind die folgenden Probleme mit Abhängigkeiten aufgetreten:

    # apt-get dist-upgrade
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Calculating upgrade... Failed
    The following packages have unmet dependencies:
    odbcinst1debian2: Breaks: libmyodbc (< 5.1.6-2) but 5.1.6-1 is to be installed
    pp12.5.30-bootstrapper: Depends: plesk-mysql-server (>= 12.5.30) but it is not going to be installed
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

    Die Lösung liegt darin, das Paket odbcinst1debian2 zu installieren und mit dist-upgrade fortzufahren:

    # apt-get install odbcinst1debian2
    ...
    # apt-get dist-upgrade
  • sasl2-bin konnte nicht eingerichtet werden

    Während dist-upgrade kann der folgende Fehler auftreten:

    Setting up sasl2-bin (2.1.25.dfsg1-6+deb7u1) ...
    saslpasswd2: user not found
    dpkg: error processing sasl2-bin (--configure):
    subprocess installed post-installation script returned error exit status 20
    Errors were encountered while processing:
    sasl2-bin
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    Um das Problem zu lösen, führen Sie das Dienstprogramm sasldbconverter2 aus und drücken Sie die Eingabetaste, sobald Sie dazu aufgefordert werden. Geben Sie dann Folgendes ein:

    # apt-get install -f

    Nachdem das Paket sasl2-bin konfiguriert wurde, führen Sie dist-upgrade aus.

  • Rsyslog konnte nicht gestartet werden

    # /etc/init.d/rsyslog restart
    [....] Starting enhanced syslogd: rsyslogd rsyslogd: [origin software="rsyslogd" swVersion="5.8.11" x-pid="1973" x-info="http://www.rsyslog.com"] start rsyslogd-2013:CONFIG ERROR: could not interpret master config file '/etc/rsyslog.conf'. [try http://www.rsyslog.com/e/2013 ] rsyslogd:EMERGENCY CONFIGURATION ACTIVATED - fix rsyslog config file!. ok

Ersetzen Sie die Konfiguration rsyslog durch die Version vor dem Upgrade und starten Sie den Dienst neu:

    # mv /etc/rsyslog.conf.saved_by_plesk_distupgrade /etc/rsyslog.conf
# /etc/init.d/rsyslog restart
[ ok ] Stopping enhanced syslogd: rsyslogd.
[ ok ] Starting enhanced syslogd: rsyslogd.

Fehler in Apache während dist-upgrade

Wenn keine Fehlermeldung bei dist-upgrade angezeigt wird, Sie jedoch die Information erhalten, dass die Apache-Pakete nicht installiert wurden, führen Sie die Installation der Pakete erneut aus und verwenden Sie dazu den folgenden Befehl. Damit wird die entsprechende Fehlermeldung angezeigt oder Sie können mit dist-upgrade fortfahren, nachdem Sie das Problem behoben haben:

# apt-get install -f
  • Konfigurationsdatei dir.conf wurde nicht ordnungsgemäß aktiviert

    Der Befehl apt-get install -f hat einen Fehler für den Apache-Dienst zurückgegeben:

    Config file dir.conf not properly enabled: /etc/apache2/mods-enabled/dir.conf is a real file, not touching it.

    Ersetzen Sie 'dir.conf' durch eine symbolische Verknüpfung und setzen Sie das Upgrade fort, wenn Apache gestartet werden kann:

    # ln -sf ../mods-available/dir.conf /etc/apache2/mods-enabled/dir.conf
  • API-Modulstruktur 1aclr_module1 ist beschädigt

    Das Upgrade schlug fehl. Die folgende Fehlermeldung wird angezeigt:

    API module structure 1aclr_module1 in file /usr/lib/apache2/modules/mod_aclr.so is garbled - expected signature 4 1503234 but saw 41503232 - perhaps this is not an Apache module DSO, or was compiled for a different Apache version?

    Das Upgrade für das Modul 'aclr' wurde nicht ordnungsgemäß durchgeführt. Das gleiche Problem kann für das Modul 'fcgi' auftreten. Deaktivieren Sie das Modul und starten Sie Apache erneut:

    # a2dismod aclr
    Module aclr disabled

    Deaktivieren Sie auch 'fcgi' mithilfe dieses Befehls, falls erforderlich. Setzen Sie das Upgrade fort, wenn Apache gestartet werden kann.

  • Keine Übereinstimmungen für den Platzhalter '*.conf'

    Der Apache-Start schlug fehl. Die folgende Fehlermeldung wird angezeigt:

    apache2: Syntax error on line 234 of /etc/apache2/apache2.conf: Syntax error on line 5 of /etc/apache2/conf.d/zz010_psa_httpd.conf: Syntax error on line 72 of /etc/apache2/plesk.conf.d/server.conf: No matches for the wildcard '*.conf' in '/etc/apache2/plesk.conf.d/ip_default', failing (use IncludeOptional if required)
    Action 'configtest' failed.
    The Apache error log may have more information.

    Führen Sie die Schritte im Artikel [KB125735]Nach dem Upgrade von Apache 2.2 auf 2.4 kann Apache nicht gestartet werden durch und setzen Sie das Upgrade fort, wenn Apache gestartet werden kann.

  • Konfigurationsdatei /etc/apache2/sites-enabled/000-default konnte nicht geöffnet werden: Keine entsprechenden Dateien oder Verzeichnisse gefunden

    Der Apache-Start schlug fehl. Die folgende Fehlermeldung wird angezeigt:

    apache2: Syntax error on line 268 of /etc/apache2/apache2.conf: Could not open configuration file /etc/apache2/sites-enabled/000-default: No such file or directory

    Entfernen Sie die symbolische Verknüpfung und setzen Sie das Upgrade fort, wenn Apache gestartet werden kann:

    # rm /etc/apache2/sites-enabled/000-default
  • Ungültiger Befehl 'LockFile'

    Der Apache-Start schlug fehl. Die folgende Fehlermeldung wird angezeigt:

    Invalid command 'LockFile', perhaps misspelled or defined by a module not included in the server configuration Action 'configtest' failed.
    The Apache error log may have more information.

    Die 'LockFile'-Anweisung ist in Apache 2.4 nicht vorhanden. Ersetzen Sie sie durch die 'Mutex'-Anweisung in /etc/apache2/apache2.conf :

    LockFile ${APACHE_LOCK_DIR}/accept.lock

    ersetzen durch

    Mutex file:${APACHE_LOCK_DIR} default

    Ersetzen Sie außerdem 'SSLMutex' durch 'Mutex' in /etc/apache2/mods-enabled/ssl.conf und fahren Sie mit dem Upgrade fort, wenn Apache gestartet werden kann.

  • SSLSessionCache: 'shmcb1'-Sitzungscache nicht unterstützt

    Der Apache-Start schlug fehl. Die folgende Fehlermeldung wird angezeigt:

    SSLSessionCache: 'shmcb1' session cache not supported (known names: ). 
    Maybe you need to load the appropriate socache module (mod_socache_shmcb?).

    Kommentieren Sie 'SSLSessionCache' in /etc/apache2/mods-enabled/ssl.conf und fahren Sie mit dem Upgrade fort, wenn Apache gestartet werden kann.

  • Ungültiger Befehl 'Order'

    Der Apache-Start schlug fehl. Die folgende Fehlermeldung wird angezeigt:

    Invalid command 'Order', perhaps misspelled or defined by a module not included in the server configuration.

    Entfernen Sie 'Order..' und 'Allow..' und fügen Sie 'Require all granted' in /etc/apache2/plesk.conf.d/server.conf in allen Abschnitten hinzu. Zum Beispiel:

    <Directory "/var/www/vhosts/default/cgi-bin">
    AllowOverride None
    Options None
    - Order allow,deny
    - Allow from all
    + Require all granted
    </Directory>

    Setzen Sie das Upgrade fort, wenn Apache gestartet werden kann.

  • Apache startete ohne Websites

    Apache wird ordnungsgemäß gestartet, es werden jedoch keine Websites geladen.
    In der Ausgabe von apache2ctl -S wird nur die Standardwebseite angeführt.

    Erstellen Sie eine symbolische Verknüpfung von /etc/apache2/conf.d/zz010_psa_httpd.conf zu /etc/apache2/conf-enabled/zz010_psa_httpd.conf .

    # ln -s /etc/apache2/conf.d/zz010_psa_httpd.conf /etc/apache2/conf-enabled/zz010_psa_httpd.conf
  • Portkonflikt mit nginx

    Der Apache-Webserver startet nach dem Upgrade auf Debian 8 nicht. Die folgende Fehlermeldung wird angezeigt:

    root@dist-upgrade:~# apache2ctl start
    (98)Address already in use: AH00072: make_sock: could not bind to address [::]:80
    (98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:80
    no listening sockets available, shutting down
    AH00015: Unable to open logs
    Action 'start' failed.
    The Apache error log may have more information.

    Das bedeutet, dass die Datei /etc/apache2/ports.conf von der Version des Paket-Maintainers überschrieben wurde und die Ports 80 und 443 jeweils für http und https verwendet werden. Es wird jedoch auch nginx ausgeführt und dabei werden die gleichen Ports verwendet.

    Um Apache so zu konfigurieren, dass die richtigen Ports verwendet werden, deaktivieren Sie den nginx Reverseproxyserver und aktivieren Sie ihn anschließend erneut:

    # plesk sbin nginxmng --disable
    # plesk sbin nginxmng --enable

    Führen Sie anschließend plesk repair web aus und fahren Sie mit dist-upgrade fort.

Hinweis : Vergessen Sie nicht, das automatische Installationsprogramm von Plesk zu verwenden, um alle verfügbaren Plesk Updates nach dist-upgrade zu installieren.

Haben Sie Fragen? Anfrage einreichen
Bitte melden Sie sich an, um einen Kommentar zu hinterlassen.